Home
Community
Manuals
Login or Signup

Blitz says that it needs Internet Explorer 4 installed but I have IE 6!

This bug was fixed as of version 1.60, so just download the latest update from the 'Account'/'Product updates' section of the web site; you'll need to be logged in to do this.

Blitz BASIC Founders Fund