Home
Community
Manuals
Login or Signup

What platforms does Blitz run on?

BlitzMax

Windows 2000/XP/Vista/7/8
MacOS X 10.3.9 or higher; Project Builder or Xcode SDK installed
Linux

Blitz3D

Blitz3D runs on any version of Windows with DirectX 7 (or above) and Internet Explorer 4 (or above) installed; this includes:

Windows 95/98/ME/2000/XP/Vista/7/8

Note that Windows NT4 is not supported by Blitz Basic or Blitz3D, as it only has DirectX versions up to 3.

BlitzPlus

BlitzPlus runs on any of the following with Internet Explorer 4 or above installed, using any version of DirectX:

Windows 95/98/ME/2000/XP/Vista/7/8

Note that these requirements (excluding Internet Explorer) apply to games created with Blitz too.

Blitz BASIC Founders Fund