Home
Products
Community
Manuals
Contact
Login or Signup

Firefox 3 Blurry Image Problem

Miscellaneous Forums/General Discussion/Firefox 3 Blurry Image Problem

QuickSilva(Posted 1+ years ago) #1
Is there a way to turn off the blurry image problem that I am getting when I go to websites such as this one,

http://www.armyoftrolls.co.uk/

in Firefox 3? It is really annoying and totally ruins the pixelart look of the site in places.

I have tried selecting zoom text only but this doesn`t fully remedy the problem :( This did not happen in Firefox 2 but I do not really want to downgrade.

Any ideas?

Thanks all,
Jason.


Rob Farley(Posted 1+ years ago) #2
Use Opera, Internet Explorer or Safari.


Warpy(Posted 1+ years ago) #3
It isn't looking blurry to me.


GaryV(Posted 1+ years ago) #4
Nice site. FWIW, it was blurry for me, but I also don't have my glasses on at the moment.


nawi(Posted 1+ years ago) #5
I don't see any blur there. You might have zoom on, try pressing CTRL and the mousescroll.


MrCredo(Posted 1+ years ago) #6
yup i think you use zoom


QuickSilva(Posted 1+ years ago) #7
No luck, still blurry here. It happens when images are enlarged. For example the title page that reads enter is enlarged for some reason. If I scroll it down to the original size it looks sharp again but then if I go into the site the page is too small and I have to scroll it back up to size.

Strange,

Jason.


Ross C(Posted 1+ years ago) #8
Perhaps it's using 3d tech to zoom images?


ShadowTurtle(Posted 1+ years ago) #9
Ctrl + 0 = default zoom


Ked(Posted 1+ years ago) #10
I don't think the "enter site" screen has anything to do with FF3. I think its just part of the website. When you enter the site though, everything is clear.

and:
Use Opera, Internet Explorer or Safari.

That doesn't solve his problem with the blurry images in Firefox. Ross C posted in a thread where people, including me, were suggesting to just install something else. His post:
For all the people mentioning firefox, yeah it is alot safer and sticks to the standards, BUT, IT DOESN'T SOLVE HIS PROBLEM!

"Yeah, i'm having a problem with my code in blitz3d"

"Hmmm, i think the best way to go is install Dark Basic Pro."



Leon Brown(Posted 1+ years ago) #11
Use Opera, Internet Explorer or Safari.

Yuck! Never ever use Internet Explorer - if it was a physical product, it would smell very bad.


TaskMaster(Posted 1+ years ago) #12
I also do not see any blur.

I opened it in both IE7 and FF3 and they look the same.


Perturbatio(Posted 1+ years ago) #13
The problem is that the image is this size:



But they've scaled it up in the markup, resulting in an interpolated image.


Genexi2(Posted 1+ years ago) #14
Firefox3 uses a bilinear filter on scaled images, and as far as I know (and read), there's no way to turn it off. There's not even a flag for it in about:config.

Personally I prefer it for 99% of the occasions it's used, but I can see why it'd be bothersome on pixel-art sites, although the one above looks perfectly fine to me.


HappyCat(Posted 1+ years ago) #15
From what's been said so far (and the fact that you can't turn this off in FF3) I'd think that the obvious (and possibly only) solution would be to scale the images to the desired size before uploading them.


Digital Anime(Posted 1+ years ago) #16

From what's been said so far (and the fact that you can't turn this off in FF3) I'd think that the obvious (and possibly only) solution would be to scale the images to the desired size before uploading them.


Totally agree, It's better to make 1 website look the same on all browsers, then telling millions of people that it won't look good in FF3 who visit the site.
And even if you could chance this within FF3, I don't think millions of people want to change their settings for just 1 site.


Otus(Posted 1+ years ago) #17
There's usually no guarantee that stretched images work consistently on browsers - some will even display them original size regardless. I'd say that's an example of bad web design.

It's too bad that there's no switch to disable blurring in scaling, but it's a rare case that it becomes a problem.


Robert Cummings(Posted 1+ years ago) #18
Its bad web design 100%. You can't even begin to guess what format people will view the web in.

Having been doing web design for a living, you always put the image at the correct size on the page, never scale it in html. But I'm guessing the author of that site doesn't really care.

I'm having a problem though with firefox 3. If you click the small down arrow on the right side of the url bar you can see all the porn sites you've visited and there is no current way to clear that. Yes I've tried everything.

So your porn will be there for all to see. If she types you and you've been to youporn, it'll remember it and pop up, no matter what settings you've used to clear it :-)

Porn for all the family in Firefox 3.


GfK(Posted 1+ years ago) #19
Luckily I've only got a load of sites pertaining to anglo-saxon runes on there, but yep, they're properly stuck.

[edit]Ah. Just googled it, and it turns out that everything you've bookmarked now shows up there, too. So if you've got a load of porn sites bookmarked, they'll still appear in auto-complete in the address bar. They show up with a yellow star next to them, so you know which are bookmarks and which aren't.


ervin(Posted 1+ years ago) #20
You can clear a lot of your "bad" links by clearing your browser history.
As for "bad" bookmarks, might be best to remove them!